User Tag List

Page 2 of 2 FirstFirst 1 2
Results 8 to 13 of 13

Thread: TC with eluna not compiled Right

  1. #8
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    86
    XP
    1,809
    Level
    11
    Thanks
    10
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by yvoms View Post
    Hehe yes, I've been producing hardstyle lately, as for the topic starter yes, visual basic 14 2015 however, did you install ll the 64 bit required files or the 32?
    Been busy lately with all kinds of things so could not reply sooner. Again i did a fresh pull, did git submodule update --init
    Ofc even before i have downloaded and installed both 32 and 64bit versions of 2008,2010,2012,2013,2015 redistributables
    and yes i always do clean solution before building. In Cmake this time i selected everything to be generated including without git and tools, warnings etc.
    On Building got no errors, just some warnings like this: warning C4267: 'return': conversion from 'size_t' to 'uint32', possible loss of data (compiling source file C:\Users\Admin\Desktop\ElunaTrinityWotlk\src\serve r\game\World\World.cpp)

    This time both auth and worldserver got built as well as lua_scripts folder.
    Everything looks like it will work fine. will download latest TC db and set all files up and test it, but im sure it will work now.

  2. #9
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    86
    XP
    1,809
    Level
    11
    Thanks
    10
    Thanked 3 Times in 3 Posts

    Unhappy

    Unfortunately does not work.
    C:\Users\Admin\Desktop\ElunaTrinityWotlk\src\serve r\database\Database\DatabaseWorkerPool.cpp:32 in DataBaseWorkerPool<class WorldDatabaseConnection>:: DataBaseWorkerPool: FATAL ERROR:
    Used MySQL library version <5.5.38> does not match the version used to compile TrinityCore <5.6.35>
    Search on forum for TCE00011.
    :(

    update: followed this advice from Vitrex here http://emudevs.com/showthread.php/58...Building-in-VB , even though the files provided are from 2014, cleaned solution and rebuilt all, added the ancient 2014 files..
    Same Error
    Last edited by Marko; 01-04-2017 at 09:57 PM. Reason: rebuild
    Achievements:
    1 year registered Level X

  3. #10
    Moderator / Eluna Dev <span style='color: #FF0000'><span class='glow_8B0000'>Rochet2</span></span>'s Avatar
    Join Date
    Apr 2013
    Location
    Finland
    Posts
    1,872
    XP
    13,718
    Level
    35
    Thanks
    95
    Thanked 595 Times in 421 Posts
    @Marko so you downloaded the files, added the libmysql.lib in cmake, compiled, and then did you move the downloaded libmysql.lib or libmysql.dll to your server root folder?
    Awards:
    Support LOL Scripter Facepalm! Raffle Winner
    rochet2.github.io - Home of great codes

  4. #11
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    86
    XP
    1,809
    Level
    11
    Thanks
    10
    Thanked 3 Times in 3 Posts
    Have moved them both to release folder, now added to root folder too (ElunaTrinityWotlk), but no use. Still same error.

  5. #12
    Moderator / Eluna Dev <span style='color: #FF0000'><span class='glow_8B0000'>Rochet2</span></span>'s Avatar
    Join Date
    Apr 2013
    Location
    Finland
    Posts
    1,872
    XP
    13,718
    Level
    35
    Thanks
    95
    Thanked 595 Times in 421 Posts
    Quote Originally Posted by Marko View Post
    Have moved them both to release folder, now added to root folder too (ElunaTrinityWotlk), but no use. Still same error.
    Either the files are invalid (probably not) or you have wrong .lib in cmake or .dll in the server root folder.
    Note that the .dll needs to be next to the worldserver.exe (in the same folder)
    Awards:
    Support LOL Scripter Facepalm! Raffle Winner
    rochet2.github.io - Home of great codes

  6. #13
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    86
    XP
    1,809
    Level
    11
    Thanks
    10
    Thanked 3 Times in 3 Posts
    only fix i managed to do was installing old mysql 5.5.38

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •