User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 7 of 12

Thread: TC with eluna not compiled Right

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    53
    XP
    1,610
    Level
    11
    Thanks
    9
    Thanked 1 Time in 1 Post

    Question TC with eluna not compiled Right

    Hey guys I just did a fresh compile of latest tc with eluna from https://github.com/ElunaLuaEngine/ElunaTrinityWotlk and the worldserver was not compiled, just auth? did i do something wrong thats strange. Used VS 2015 x64bit

    p.s. got no errors when compiling, all went well. But no worldserver.exe this my first time compiling tc merged with eluna so i might be missing something
    Last edited by Marko; 12-16-2016 at 03:12 PM. Reason: no errors
    Achievements:
    1 year registered Level X

  2. #2
    Exalted Member yvoms's Avatar
    Join Date
    Dec 2014
    Location
    The Netherlands
    Posts
    255
    XP
    3,280,606
    Level
    364
    Thanks
    30
    Thanked 52 Times in 29 Posts
    Compiling right now, i'll let you know what happens for me, what settings where you using for cmake?
    Achievements:
    Member Referrer Got a Sticky! Shopper 1 year registered Level XL Level C
    Awards:
    LOL Raffle Winner Support Drunk

    - Burning Crusade Realms.


    "Peace and prosperity lets life flow on. -Katos"


  3. #3
    Exalted Member yvoms's Avatar
    Join Date
    Dec 2014
    Location
    The Netherlands
    Posts
    255
    XP
    3,280,606
    Level
    364
    Thanks
    30
    Thanked 52 Times in 29 Posts
    Update :

    Just compiled, including tools etc, everything included, latest revision etc, cloned 15 minutes ago or so.
    ========== Rebuild All: 23 succeeded, 0 failed, 0 skipped ==========
    http://prntscr.com/dk8gkc
    Achievements:
    Member Referrer Got a Sticky! Shopper 1 year registered Level XL Level C
    Awards:
    LOL Raffle Winner Support Drunk

    - Burning Crusade Realms.


    "Peace and prosperity lets life flow on. -Katos"


  4. #4
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    53
    XP
    1,610
    Level
    11
    Thanks
    9
    Thanked 1 Time in 1 Post
    This is strange yvoms, thank you for responding so fast btw. for cmake settings i used visual studio 14 2015 win64, used default native compilers..

    ========== Build: 22 succeeded, 2 failed, 0 up-to-date, 1 skipped ==========
    no worldserver.exe maybe it fails because cpu usage runs through to 100% ?

  5. #5
    Enthusiast
    Join Date
    Oct 2015
    Posts
    98
    XP
    1,391
    Level
    10
    Thanks
    19
    Thanked 10 Times in 10 Posts

    Red face

    Quote Originally Posted by yvoms View Post
    Update :

    Just compiled, including tools etc, everything included, latest revision etc, cloned 15 minutes ago or so.
    ========== Rebuild All: 23 succeeded, 0 failed, 0 skipped ==========
    http://prntscr.com/dk8gkc
    Hardstyle template?

  6. #6
    Exalted Member yvoms's Avatar
    Join Date
    Dec 2014
    Location
    The Netherlands
    Posts
    255
    XP
    3,280,606
    Level
    364
    Thanks
    30
    Thanked 52 Times in 29 Posts
    Quote Originally Posted by jonmii View Post
    Hardstyle template?
    Hehe yes, I've been producing hardstyle lately, as for the topic starter yes, visual basic 14 2015 however, did you install ll the 64 bit required files or the 32?
    Achievements:
    Member Referrer Got a Sticky! Shopper 1 year registered Level XL Level C
    Awards:
    LOL Raffle Winner Support Drunk

    - Burning Crusade Realms.


    "Peace and prosperity lets life flow on. -Katos"


  7. #7
    Original Poster
    Enthusiast Marko's Avatar
    Join Date
    Feb 2015
    Location
    Serbia
    Posts
    53
    XP
    1,610
    Level
    11
    Thanks
    9
    Thanked 1 Time in 1 Post
    Quote Originally Posted by yvoms View Post
    Hehe yes, I've been producing hardstyle lately, as for the topic starter yes, visual basic 14 2015 however, did you install ll the 64 bit required files or the 32?
    Been busy lately with all kinds of things so could not reply sooner. Again i did a fresh pull, did git submodule update --init
    Ofc even before i have downloaded and installed both 32 and 64bit versions of 2008,2010,2012,2013,2015 redistributables
    and yes i always do clean solution before building. In Cmake this time i selected everything to be generated including without git and tools, warnings etc.
    On Building got no errors, just some warnings like this: warning C4267: 'return': conversion from 'size_t' to 'uint32', possible loss of data (compiling source file C:\Users\Admin\Desktop\ElunaTrinityWotlk\src\serve r\game\World\World.cpp)

    This time both auth and worldserver got built as well as lua_scripts folder.
    Everything looks like it will work fine. will download latest TC db and set all files up and test it, but im sure it will work now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •