User Tag List

Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 8 to 14 of 23

Thread: How to install and setup Boost

  1. #8
    Respected Member
    Join Date
    Aug 2013
    Posts
    56
    XP
    3,293
    Level
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you i did fix the error now bump / love from here :D

  2. #9
    Noble Member Seraphim's Avatar
    Join Date
    Mar 2014
    Location
    United States
    Posts
    82
    XP
    49,981
    Level
    69
    Thanks
    14
    Thanked 13 Times in 7 Posts
    This is great. Considering it's already helped someone. ^.^

  3. #10
    Enthusiast
    Join Date
    Sep 2014
    Posts
    35
    XP
    1,797
    Level
    11
    Thanks
    2
    Thanked 7 Times in 4 Posts
    i did it again it works now thanks !

    - - - Updated - - -

    Detected 32-bit platform
    MSVC: Enabled large address awareness
    MSVC: Enabled SSE2 support
    MSVC: Overloaded standard names
    MSVC: Disabled NON-SECURE warnings
    MSVC: Disabled POSIX warnings
    MSVC: Disabled generic compiletime warnings
    Found OpenSSL library: optimized;C:/OpenSSL-Win32/lib/VC/ssleay32MD.lib;C:/OpenSSL-Win32/lib/VC/libeay32MD.lib;debug;C:/OpenSSL-Win32/lib/VC/ssleay32MDd.lib;C:/OpenSSL-Win32/lib/VC/libeay32MDd.lib
    Found OpenSSL headers: C:/OpenSSL-Win32/include
    Boost version: 1.56.0
    Found the following Boost libraries:
    system
    thread
    program_options
    Found MySQL library: C:/Program Files/MySQL/MySQL Server 5.5/lib/libmysql.lib
    Found MySQL headers: C:/Program Files/MySQL/MySQL Server 5.5/include
    Found git binary : C:/Program Files (x86)/Git-1/cmd/git.cmd

    * TrinityCore revision : 3bd9095009cd 2014-09-21 00:11:33 +0300 (master branch)

    * Install core to : C:/Program Files (x86)/TrinityCore

    * Build world/auth : Yes (default)
    * Build with scripts : Yes (default)
    * Build Eluna LuaEngine : Yes (default)
    * Build map/vmap tools : No (default)
    * Build core w/PCH : Yes (default)
    * Build scripts w/PCH : Yes (default)
    * Show compile-warnings : No (default)
    * Use coreside debug : No (default)
    * Use MySQL sourcetree : No
    * Use GIT revision hash : Yes

    SCRIPT PREPARATIONS
    -> Prepared: Spells
    -> Prepared: Commands
    -> Prepared: Examples
    -> Prepared: Custom
    -> Prepare: Pet
    SCRIPT PREPARATION COMPLETE

    Boost version: 1.56.0
    Found the following Boost libraries:
    system
    filesystem
    Configuring done

  4. The Following User Says Thank You to cliffsmits For This Useful Post:


  5. #11
    Original Poster
    Founder <span style='color: #FF4500'>Tommy</span>'s Avatar
    Join Date
    Apr 2013
    Posts
    7,399
    XP
    3,449,919
    Level
    378
    Thanks
    891
    Thanked 1,859 Times in 1,121 Posts
    Great to hear, you're welcome. :P

  6. #12
    Banned
    Join Date
    Sep 2014
    Posts
    48
    Thanks
    1
    Thanked 8 Times in 5 Posts
    It should be noted that you could need both binaries. I tried 32/64 bit binaries in standalone but to no avail. But when I installed both of the binaries, it worked like a charm. Not sure why that is.

  7. #13
    Original Poster
    Founder <span style='color: #FF4500'>Tommy</span>'s Avatar
    Join Date
    Apr 2013
    Posts
    7,399
    XP
    3,449,919
    Level
    378
    Thanks
    891
    Thanked 1,859 Times in 1,121 Posts
    Quote Originally Posted by Tankinstein View Post
    It should be noted that you could need both binaries. I tried 32/64 bit binaries in standalone but to no avail. But when I installed both of the binaries, it worked like a charm. Not sure why that is.
    There's probably an explanation for how that could've been a coincidence.

  8. #14
    Emulation Addict
    Join Date
    Feb 2015
    Posts
    1
    XP
    1,071
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Detected 32-bit platform
    MSVC: Enabled large address awareness
    MSVC: Enabled SSE2 support
    MSVC: Disabled Safe Exception Handlers for debug builds
    MSVC: Overloaded standard names
    MSVC: Disabled NON-SECURE warnings
    MSVC: Disabled POSIX warnings
    MSVC: Disabled generic compiletime warnings
    Found OpenSSL library: optimized;C:/OpenSSL-Win64/lib/VC/ssleay32MD.lib;C:/OpenSSL-Win64/lib/VC/libeay32MD.lib;debug;C:/OpenSSL-Win64/lib/VC/ssleay32MDd.lib;C:/OpenSSL-Win64/lib/VC/libeay32MDd.lib
    Found OpenSSL headers: C:/OpenSSL-Win64/include
    Found ZMQ library: C:/ZeroMQ 4.0.4/lib/libzmq-v90-mt-4_0_4.lib
    Found ZMQ headers: C:/ZeroMQ 4.0.4/include
    CMake Warning (dev) at cmake/macros/FindBoost.cmake:344 (if):
    Policy CMP0054 is not set: Only interpret if() arguments as variables or
    keywords when unquoted. Run "cmake --help-policy CMP0054" for policy
    details. Use the cmake_policy command to set the policy and suppress this
    warning.

    Quoted variables like "MSVC" will no longer be dereferenced when the policy
    is set to NEW. Since the policy is not set the OLD behavior will be used.
    Call Stack (most recent call first):
    cmake/macros/FindBoost.cmake:741 (_Boost_GUESS_COMPILER_PREFIX)
    cmake/macros/ConfigureBoost.cmake:28 (find_package)
    CMakeLists.txt:61 (include)
    This warning is for project developers. Use -Wno-dev to suppress it.

    CMake Error at cmake/macros/FindBoost.cmake:1115 (message):
    Unable to find the requested Boost libraries.

    Boost version: 1.57.0

    Boost include path: C:/local/boost_1_57_0

    Could not find the following static Boost libraries:

    boost_system
    boost_thread
    boost_program_options

    No Boost libraries were found. You may need to set BOOST_LIBRARYDIR to the
    directory containing Boost libraries or BOOST_ROOT to the location of
    Boost.
    Call Stack (most recent call first):
    cmake/macros/ConfigureBoost.cmake:28 (find_package)
    CMakeLists.txt:61 (include)


    Found MySQL library: C:/xampp/mysql/lib/libmysql.lib
    Found MySQL headers: C:/xampp/mysql/include
    Found git binary : C:/Program Files (x86)/Git/cmd/git.exe

    Could not find a proper repository signature (hash) - you may need to pull tags with git fetch -t
    Continuing anyway - note that the versionstring will be set to "unknown 1970-01-01 00:00:00 (Archived)"

    * TrinityCore revision : unknown 1970-01-01 00:00:00 +0000 (Archived branch)

    * Install core to : C:/Program Files (x86)/TrinityCore

    * Build world/auth : Yes (default)
    * Build with scripts : Yes (default)
    * Build map/vmap tools : No (default)
    * Build core w/PCH : Yes (default)
    * Build scripts w/PCH : Yes (default)
    * Show compile-warnings : No (default)
    * Use coreside debug : No (default)
    * Use MySQL sourcetree : No
    * Use GIT revision hash : Yes

    SCRIPT PREPARATIONS
    -> Prepared: Spells
    -> Prepared: Commands
    -> Prepared: Custom
    -> Prepared: World
    -> Prepared: Outdoor PVP Zones
    -> Prepared: Eastern Kingdoms
    -> Prepared: Kalimdor
    -> Prepared: Outland
    -> Prepared: Northrend
    -> Prepared: The Maelstrom
    -> Prepared: Events
    -> Prepared: Pet
    SCRIPT PREPARATION COMPLETE

    Configuring incomplete, errors occurred!
    See also "C:/Users/Justin/Desktop/Bin/CMakeFiles/CMakeOutput.log".
    See also "C:/Users/Justin/Desktop/Bin/CMakeFiles/CMakeError.log".
    Got that Error, can someone help me with that?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •