User Tag List

Page 5 of 14 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast
Results 29 to 35 of 96

Thread: [Trinitycore] Transmogrification 3.3.5a

  1. #29
    Banned
    Join Date
    Dec 2013
    Location
    california
    Posts
    637
    Thanks
    133
    Thanked 81 Times in 47 Posts
    then please give me a guide because it tells me that it cant apply the patch and gives massive errors when trying to apply it saying syntax error that the patch cant be merged etc

  2. #30
    Original Poster
    Moderator / Eluna Dev <span style='color: #FF0000'><span class='glow_8B0000'>Rochet2</span></span>'s Avatar
    Join Date
    Apr 2013
    Location
    Finland
    Posts
    1,860
    XP
    13,531
    Level
    35
    Thanks
    95
    Thanked 591 Times in 418 Posts
    Quote Originally Posted by ssfrostic View Post
    then please give me a guide because it tells me that it cant apply the patch and gives massive errors when trying to apply it saying syntax error that the patch cant be merged etc
    Try git apply --check -v Transmogrification.diff

    This will not actually apply the patch, it will just show the errors.
    Then show us the errors so we know what is going on exactly and how to guide forward.

    I think there might have been a TC update, or then your source is old or then you have custom scripts or then there are multiple of these problems at once :)
    Last edited by Rochet2; 01-25-2014 at 05:59 PM.
    Awards:
    Support LOL Scripter Facepalm! Raffle Winner

  3. #31
    Banned
    Join Date
    Dec 2013
    Location
    california
    Posts
    637
    Thanks
    133
    Thanked 81 Times in 47 Posts
    i got it to work. for some odd reason a few of the source files was broken :/ im guessing cmake caused the issues. as like about 15 scripts had missing () marks in them and about 5 files was not even loaded. how i fixed it. re-downloaded trinity source re-added my custom scripts applied the patch and now it is working thanks :)

  4. #32
    Enthusiast
    Join Date
    May 2013
    Location
    SHANGHAI
    Posts
    35
    XP
    2,412
    Level
    13
    Thanks
    20
    Thanked 2 Times in 2 Posts
    Thanks a lot!
    Maybe I first learned compiler technology, and I want to Localization,for example set gossip menu to Chinease. when I compiled,All options garbled, can you tell me how to modiy it,or maybe you can set all menu into DB,it will help for us to lacalization.
    sorry for my bad English.

  5. #33
    Original Poster
    Moderator / Eluna Dev <span style='color: #FF0000'><span class='glow_8B0000'>Rochet2</span></span>'s Avatar
    Join Date
    Apr 2013
    Location
    Finland
    Posts
    1,860
    XP
    13,531
    Level
    35
    Thanks
    95
    Thanked 591 Times in 418 Posts
    Quote Originally Posted by sandyqyh View Post
    Thanks a lot!
    Maybe I first learned compiler technology, and I want to Localization,for example set gossip menu to Chinease. when I compiled,All options garbled, can you tell me how to modiy it,or maybe you can set all menu into DB,it will help for us to lacalization.
    sorry for my bad English.
    Might do an update to reintroduce localization possibility, but not at this time.
    The item names should be localized already if you have the DBCs on your server.

  6. #34
    Enthusiast
    Join Date
    May 2013
    Location
    SHANGHAI
    Posts
    35
    XP
    2,412
    Level
    13
    Thanks
    20
    Thanked 2 Times in 2 Posts
    items name is right,but gossip menu wrong,for example menu text is "head","back……","How transmogrification works" and so on.
    Now I try to modify Transmogrifier.cpp and Transmogrification.cpp,for example :
    your code:
    player->ADD_GOSSIP_ITEM(GOSSIP_ICON_MONEY_BAG, "|TInterface/ICONS/INV_Misc_Book_11:30:30:-18:0|tHow transmogrification works", EQUIPMENT_SLOT_END+9, 0);
    and I modified it to
    player->ADD_GOSSIP_ITEM(GOSSIP_ICON_MONEY_BAG, "|TInterface/ICONS/INV_Misc_Book_11:30:30:-18:0|t XXXXXX my language (CHINA)", EQUIPMENT_SLOT_END+9, 0);

    After generating compiled,in game the menu text garbled,I don't know why……

    Thanks a lot,I have solved.
    Last edited by sandyqyh; 02-25-2014 at 12:19 PM.
    Achievements:
    1 year registered Member Level X

  7. #35
    Enthusiast
    Join Date
    Feb 2014
    Posts
    15
    XP
    1,838
    Level
    11
    Thanks
    0
    Thanked 6 Times in 1 Post

    Little issue

    Hi all,

    First of all, thank you Rochet for all script that you give.

    However i got issues with the transmog, I apply the diff file in my TrinityCore/ (i'm on Debian), then i re-compile, everything is fine. I run sql files, i edit the worldserver.conf with the new one.
    It compile without problem, but when i add the npc @entry 190010, he just says "Greetings", nothing else.

    I searched for a while but i didn't find a good answer.

    I'm on TrinityCore 3.3.5a, i never modifier the core, i only modified sql.

    Can someone help me please ?

    PS : Sorry for my bad English, i try my best.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •