Compiled a fresh trihnitycore release and try to start to develop my server with trinitycore for cataclysm, work in past revisions of trinitycore and loading correctly transports but in the latest revision don't work,

use the lastest tdb and updates and rev of core for more information link de gdb output

try diferent db versions and the result is exactly.
same result using eluna for cataclysm, for more information use the ACE library versions 6.0.3.