View Full Version : Compiler error

07-05-2016, 07:12 PM
hey i have eluna and trinity together

and ive already set the environ variables to BOOST_ROOT

and i keep getting

CMake Error at cmake/macros/FindBoost.cmake:1185 (message):
Unable to find the requested Boost libraries.

Unable to find the Boost header files. Please set BOOST_ROOT to the root
directory containing Boost or BOOST_INCLUDEDIR to the directory containing
Boost's headers.
Call Stack (most recent call first):
dep/boost/CMakeLists.txt:29 (find_package)

any help ?

- - - Updated - - -

i also added # set boost-directory
set (ENV{BOOST_ROOT} "C:/local/boost_1_59_0/boost/")

to cmakemlist.txt and it still wont make the .sln file and im using vs 2013 #4

07-05-2016, 08:21 PM
Is that the correct path? Your path should be the parent boost directory. Look at the image below for elaboration:


So my BOOST_ROOT path will be "C:\boost_1_60_0", for example. In other words, make sure your path is the correct path, else it cannot find what it is looking for.

07-05-2016, 08:45 PM
yes that is the correct path

07-05-2016, 09:17 PM
can you post your cmakelists.txt file plz

07-06-2016, 11:23 AM
Any help ?

07-06-2016, 02:50 PM
Remove the cmakelists modification you made

can you post your cmakelists.txt file plz
Mine is default, which you can find from the TC repository https://github.com/TrinityCore/TrinityCore

Post exactly what you set in the environment variables.
Post where you downloaded boost from. (exactly, not just "boost.org")
Post which boost you downloaded exactly.
Post if you chose the 64 bit compiler in cmake.

You might have wrong path, for example it might have ending / or \ even though it should not be there or something
or you might have downloaded incorrect boost that:
- doesnt have binaries
- is for some other compiler
- is for wrong bit version
If you know some of these, post them also in addition to posting where you downloaded boost form.

try post all info : )

Try setting both the system and the user specific environment variable to the same boost path.

My BOOST_ROOT is set to E:/Programs/boost/boost_1_60_0/
Try using similar slashes.

07-06-2016, 11:22 PM
fyi with my 2 cents worth lol .
when I installed Boost x64, it installed by default to C:\local\boost_1_60_0

07-18-2016, 07:17 PM
check, your system bit and look cmake bit is correct or no when configuring