View Full Version : [Request] How to remove the Runeforge requirement

03-27-2016, 10:32 AM
Hello, I am looking for a way to remove the Runeforge requirement in the death knights so called "proffesion" Runeforging.
Would be so grateful, if anyone knows how to do that.

Thanks in advance!

03-31-2016, 06:42 AM
You need to edit Spell.dbc. Using Stoneharry's Spell Editor is a good method of doing this.

You want to look up the spellID from a database. Using Razorice with ID 53343 as an example. Open it up in spell editor and change Requires Spell Focus to none. It's under "Base" tab.

Here (http://i.imgur.com/7sxQGMV.png) is a screenshot of the looks. Top right - not sure if you'll need to distribute it to clients, or if having a server is enough. Might be just fine to be serverside but clientside it'll be saying "Requires: Runeforge" still.

03-31-2016, 05:13 PM