View Full Version : [SOLVED] Cmake issues

09-28-2014, 03:12 PM
309Hey guys, so im having some serious issues lol, alright so last night i was able to compile my 3.3.5 trinity core, and then today i had wayyy to many folders lieing around and so i was deleting games, and my pc game folder, and all my server stuff was in that folder, I go to look for it later on, and i cant find it so i decide to make another, i get up to the part where i have to use cmake ( ive deleted and reinstalled boost to the default - C:\local\Boost_1_56_0
and i put it in my variables, but when i go in and try and run it on visual 12, this is what i get CMake Error at cmake/macros/FindBoost.cmake:1115 (message):
Unable to find the requested Boost libraries.

Unable to find the Boost header files. Please set BOOST_ROOT to the root
directory containing Boost or BOOST_INCLUDEDIR to the directory containing
Boost's headers.
Call Stack (most recent call first):
cmake/macros/ConfigureBoost.cmake:28 (find_package)
CMakeLists.txt:60 (include)
, can anyone help me at all? i had it just fine and dandy yesterday morning and now nothing like wtf, im willing to have someone use team veiwer or skype screenshare to see if they can guide me or do it for me if at all possible, thank you :) and before you say look at other threads, i have been up all night searching emudevs. and google trying to find my issue and a resolvment, everytime i see one, i do what it says but nothing, happens, please let me know :) thanks
- edit i see what i did in the pic, the error, but i fixed it , becuase i had just edited it before i posted this post

-EDIT- i fixed what it was, and will be making a tutorial over what i did and how to compile it with out anyissues hopefully, so go ahead and close this admins :):date:

09-30-2014, 07:47 AM
Try installing 32 and 64 bit binaries, for anybody who looks at this for the same issue.

10-03-2014, 05:43 AM
BOOST_ROOT is all you need in your System variables. Remove the others. Did you look at my tutorial? It will help: http://emudevs.com/showthread.php/3864-How-to-install-and-setup-Boost

For example:


As I said, BOOST_ROOT is all you need. Make sure they are 32bit binaries. 64bit binaries are only for compiling in 64bit. I see that you have both 64 and 32 bit binaries? If you're only compiling in 32 bit, delete the 64 bit because you won't need it unless you want to compile via 64 bit.

It can't find boost because you probably didn't give the correct path in your System Variables.

Make sure the path contains the boost files:

My path is: C:\boost_1_56_0



If you have CMake running and you edited the environment variables CMake would need to be restarted to reload your edit(s).