View Full Version : Itemupgradenpc

07-13-2014, 06:56 PM

i made a new script for an itemupgrade npc but every time i use him and log out after this the server crashes.

the only msg i get from the eluna log is this.

2014-07-13_21:01:22 ERROR [Eluna]: Ending event 42 for PlayerEvents, stack top was 1 and was supposed to be between 0 and 1. Report to devs

and i dont know what to do with this.

here is the script http://pastebin.com/7X8r9RLi

i hope u guys can help me :D

07-13-2014, 07:03 PM
You sure it's the script?

07-13-2014, 07:05 PM
The script is likely unrelated to the error message
is the event and its not in the script you posted.
lua_gettop(L) > _LuaStackTop + _LuaFuncCount * _LuaReturnValues
1 > 1
So Im guessing this was already fixed.

Try getting a crashlog by compiling in debug, crashing the core and sending the log here.
Otherwise try update eluna.

Most likely both are old errors that were fixed unless you are on the latest Eluna version.

07-13-2014, 07:06 PM
i think so because its only when i "upgrade" a item....

- - - Updated - - -

okay then i try to update this ^^

07-13-2014, 08:36 PM
so after the update same thing without an error in the eluna log
and this is the error i dont know why there is no log...


and when i remove player:RemoveItem(600191, 1) the server doesnt crash...

07-13-2014, 09:26 PM
Im unable to get a crash.

Can you tell as an example exactly what options you click? I tried the first and then the first.
Also, would it be possible to get a crash log? This would mean compiling in debug, crashing the core and seeing the crashes folder.
Additionally it would be great to get the items you test with. (especially probably the currency item)

07-14-2014, 09:38 AM
at first i buy the torment 1 and then i upgrade it to torment 2

here are the items http://pastebin.com/4SpxcUCS

the crash also occurs when i use the command .saveall

to compile it in debug wich option have i to choose

opsys: Linux

07-14-2014, 10:45 AM
pls make it solved....
after the update the error doesnt occurs
i feel a bit dumb now xD i started the wrong core...

07-14-2014, 03:40 PM
Marking as solved lol