View Full Version : Failed attempts at updating to the latest Eluna Core

02-03-2014, 10:52 AM
So, I have an outdated version of Eluna on my trinitycore server, and have just found this out yesterday. Since then I've been trying to get the latest version working on my computer. Everything compiles normally and fine[I think], I run the mysql, I connect to the mysql[I use faded-sql] with username: root; password: root; run the auth_database.sql and characters_database.sql, thus filling the databases I created in the mysql, then I run the latest TBD_FULL_335.52... to fill up the world database. It all runs okay for the most part, a few minor errors that I'm sure don't pertain to this issue, which I'm leading up to.

So then I make sure my authserver.conf and worldserver.conf have the correct usernames and passwords for connecting to the DB[root and root, respectively]. Then I run the authserver, it runs and connects fine to the DB. Run the worldserver next, but for some reason it says it cant connect with the username:root, password:root. I've seen and searched for other threads pertaining to my problem but still have not found a solution. I even tried following multiple videos/threads, trying to build the core over again on how they [sometimes]vaguely say what to do.. One video I followed and hoped would work was this one http://www.youtube.com/watch?v=JRm9ZfZnsIE

I followed that video exactly[well almost, there's no longer a https://github.com/ElunaLuaEngine/Source just a: https://github.com/ElunaLuaEngine/Eluna-TC-Wotlk that had similar looking files], get the source files how he got them, build it with c-make, open TrinityCore.sln in the build-path, then releasing it as win-32. I'm doing something incorrectly during the process, I know it, and I've spent the last 7-8 hours trying to figure it out. Please, if you know how to fix this issue or require more information, just ask. I'm not very good at any of this: Building cores, making forum posts once that anyone can understand and then help me with my problem[always seem to leave something that they want, out].. Anyways, thanks for reading this huge wall of text.

02-03-2014, 11:17 AM
If the compilation succeeds and the server starts up and cant connect, it is likely a problem with your MySQL and the login credentials.
: |

02-03-2014, 11:46 AM
But I run an older version of Eluna on a trinity-core just fine. It connects and runs perfectly. I just want an updated version of Eluna..

02-03-2014, 11:49 AM
Are you sure it cant connect or if there is some other error that halts the process.
You havent posted any errors or anything here.

Eluna was updated to latest TC a while ago.

02-03-2014, 12:28 PM
"DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database;3306;root;ascent;world"

I rebuilt another new server again to get and post that error. btw I switched what mysql I used. so the mysql password is indeed ascent. The auth-server can connect with the same credentials as the world-server. Yet the world-server still can't connect.

02-03-2014, 01:09 PM
Hi there everyone in the future reading this who is having similar problems. I have fixed it. I did it by using this thread http://emudevs.com/showthread.php/1450-Combine-SQL?highlight=Windows+merge+SQL
to merge sql-update files from the latest revision located in C:\_Cores\Trinity\Eluna-TC-Wotlk\sql\updates
Just make the bat, put it in your source folder so in my case C:\_Cores\Trinity\Eluna-TC-Wotlk\
and then run the new combined sql in your world file and no longer get the "DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database;3306;root;ascent;world" whenever you start your server up. I hope this helps someone later on who has this same issue. A moderator if you will. Can now mark this as resolved.

02-03-2014, 01:40 PM
So you had not run SQL updates :)

02-03-2014, 01:51 PM
Yea haha, I kept getting errors running them before, and for some reason they worked this time. Pretty happy right now hahaaha

02-03-2014, 03:34 PM
i would just sit and do a few at a time to avoid the errors from missing or allready added ........ sux

>>here (http://emudevs.com/showthread.php/1450-Combine-SQL?highlight=Windows+merge+SQL)<<

nvm i think this is it ^^
i think this is the right one lol if not let me know.
if this does the sql updates better and proper than I can wooohooo

02-03-2014, 04:39 PM
Marked as solved :)