View Full Version : [SOLVED] Attack power and spell power shows "0"

01-18-2014, 12:09 PM
Okay, so basically i've edited in the core so I can have like stats over 32k, which works, but when I have like over 60k attack power and spell power it shows as a "0", does anyone know how to fix this, or where in compile I can edit this?

Also another thing, I've made custom npc, quests and items, how can I save those sqls and run it in when I recompile?

Thanks in advance! :)

01-18-2014, 02:10 PM
I think this is a client-side problem. You have to edit some DBC's, im sure. Tommy or anyone, can you point which DBC should be edited to display those stats?

01-18-2014, 02:36 PM
Oh okei :)

01-18-2014, 03:24 PM
it's not an client side problem, have you changed the db column data types from smallint to regular int?

01-18-2014, 03:38 PM
Yes, I have changed the stat_values from smallint to int

01-18-2014, 04:08 PM
Yes, I have changed the stat_values from smallint to int

Then you probably forgot to change GetUInt16() to GetUInt32().

smallint actually shows values of 32,767 to 32,767. I'm sure you'll exceed those numbers too.. Anyway, make sure it isn't loading a unsigned short when it loads the stats from the database in the source code.

01-18-2014, 04:19 PM
It's wierd though, because I can have stats over 500k, and it's working, but on some classes the attack power and spell power shows "0", my paladin, has like 200k attack power and it's showing, but my dk shows 0 when it reaches over 60k

01-18-2014, 04:36 PM
i had same problem, this is client side problem.

Next time use search ;)

01-18-2014, 07:06 PM
Ahh, okay, thanks :)