View Full Version : [SOLVED] mangos 1.12.1 cmake error, BZIP2_INCLUDE_DIR-NOTFOUND

11-08-2013, 02:32 AM
hi all, i thought i should updatame my server and i saw that they have moved to cmake.

i use windows and VC 2010 ulty.

i don't know why cuz i really liked to old system, cuz that maed it as an portable project. i used to do stuffs from my USB but now i can anymore.

so yea i tryd to cmake it and i get this error:


if anyone know how i can fix i will be really greatfull to him/her

i try to dlownload this files but i don't know what to do whit it^^


thx for you help.

11-08-2013, 02:46 AM
Since I've never used mangos zero idk if removing it as a dependency would be a good idea
but here is a link to a windows install of it http://gnuwin32.sourceforge.net/downlinks/bzip2.php

11-08-2013, 03:02 AM
i tryd to install that one but it still gibe me the same error...

11-08-2013, 05:17 AM
Did you define a path on the cmake after you installed it? Is Bzip even needed?

11-08-2013, 06:32 AM
Install BZIP and change " Value" to path where you installed it.

11-11-2013, 02:36 AM
ok thx. i get that working and the Zlib, but now i have get:


so as you may can see now its (missing: ACE_INCLUDE_DIRS) i ahve tryd to find it on google but are not sure on what i should take. sorry if this is nooby stuffs but i ahve never get this kinda error befor and then ia hve then this for like 5 years, ia hve learned mostly by try and error and a few inputs from ppl.

11-11-2013, 02:50 AM
Uhm.. Doesn't this mangos version come with the ace wrappers?

11-11-2013, 03:31 AM
my map looks like this:


so no, i think they have never build that in. trinity has but not mangos i guess. i think this is ther first Cmake one cuz they have never used it before.

11-11-2013, 03:53 AM
They all include ACE, not sure what's up with this version of mangos.

If you look at the bottom readme on https://github.com/mangoszero/server under dependencies, there is a link to ACE if you need to install manually for the libraries

11-11-2013, 08:06 AM
thx for th help but i nearly think why even try when they are just f**king it up all the thime they cahnge from good stuffs to maybe better but in a way so you can't get the thing to work.^^ maybe i should skip 1.12.1 and go 3.3.5 like all other ppl. so boring but othing to do:(